Discussion:
IBM ISIM/IGI Sybase Adapter.
(too old to reply)
g***@gmail.com
2019-10-22 20:18:47 UTC
Permalink
Hi, we are trying to configure Sybase adapter and fount his error during the connection test.

ERROR [AssemblyLine.AssemblyLines/SybaseManageUserAL_Sybase Heredadas_test-no-requestid_6313d86c-2c1d-11b2-1a86-00000a824690] - Communication error occurred while establishing connection with the Sybase database : CTGDIJ109E NO SE PUEDE CONECTAR CON LA BASE DE DATOS (JZ0LA: FAILED TO INSTANTIATE CIPHER OBJECT. TRANSFORMATION RSA/NONE/OAEPWITHSHA1ANDMGF1PADDING IS NOT IMPLEMENTED BY ANY OF THE LOADED JCE PROVIDERS.). VERIFIQUE QUE TODOS LOS PARÁMETROS DE CONEXIÓN DE LA BASE DE DATOS ESTÉN ESPECIFICADOS CORRECTAMENTE.

The only information i could find is this Sybase documentation:

http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc39001.0707/html/prjdbc0707/CIHGFHDI.htm

this sybase documentation would solve this issue or should i download the IBMJCE jar file???
Jason Williams
2019-10-23 17:18:45 UTC
Permalink
Post by g***@gmail.com
Hi, we are trying to configure Sybase adapter and fount his error during the connection test.
ERROR [AssemblyLine.AssemblyLines/SybaseManageUserAL_Sybase Heredadas_test-no-requestid_6313d86c-2c1d-11b2-1a86-00000a824690] - Communication error occurred while establishing connection with the Sybase database : CTGDIJ109E NO SE PUEDE CONECTAR CON LA BASE DE DATOS (JZ0LA: FAILED TO INSTANTIATE CIPHER OBJECT. TRANSFORMATION RSA/NONE/OAEPWITHSHA1ANDMGF1PADDING IS NOT IMPLEMENTED BY ANY OF THE LOADED JCE PROVIDERS.). VERIFIQUE QUE TODOS LOS PARÁMETROS DE CONEXIÓN DE LA BASE DE DATOS ESTÉN ESPECIFICADOS CORRECTAMENTE.
http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc39001.0707/html/prjdbc0707/CIHGFHDI.htm
this sybase documentation would solve this issue or should i download the IBMJCE jar file???
With the error mentioning that it is related to a cipher issue, I will make an assuming the JVM my be out dated. In a review of the ISIM 7 Sybase Adapter release note, it recommends being on at least 7.2.0-ISS-SDI-LA0008 JVM update. SDI recommend fixes can be found at http://www.ibm.com/support/docview.wss?uid=swg27010509

If the problem persist after moving to a current JVM, I would open a case with IBM Support (www.ibm.com/mysupport)
Loading...