Discussion:
Server start fails on RHEL 7.1 (Maipo)
(too old to reply)
a***@gmail.com
2015-11-20 15:55:36 UTC
Permalink
Moved to RHEL 7.1 , installed SDI V7.2 ( 7.1.1 works fine) with FP 3. on start of ibmditk get this error in the logs:
2015-11-20 15:46:28,929 ERROR [com.ibm.di.loader.ServerLauncher] - CTGDKG023E Error while starting main class.
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:88)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:55)
at java.lang.reflect.Method.invoke(Method.java:613)
at com.ibm.di.loader.ServerLauncher.startServer(ServerLauncher.java:173)
at com.ibm.di.loader.ServerLauncher.main(ServerLauncher.java:79)
Caused by: java.lang.UnsatisfiedLinkError: i4clntjni (Not found in java.library.path)

So how do I fix the Link Error?
Steve
@ErikSorensen
2015-11-20 17:02:55 UTC
Permalink
http://www-01.ibm.com/support/docview.wss?uid=swg21664124
a***@gmail.com
2015-11-23 13:25:36 UTC
Permalink
Post by @ErikSorensen
http://www-01.ibm.com/support/docview.wss?uid=swg21664124
Thanks for the ref but every report that gets generated gives: Service Unavailable - DNS failure
The server is temporarily unable to service your request. Please try again later.
@ErikSorensen
2015-11-23 20:09:27 UTC
Permalink
yeah - prereq site is down for me too. try checking that compat-libstdc++ (both 32 and 64 bit) are installed. if not, uninstall TDI, install them... then reinstall TDI and see what happens.
a***@gmail.com
2015-11-23 22:20:50 UTC
Permalink
Post by @ErikSorensen
yeah - prereq site is down for me too. try checking that compat-libstdc++ (both 32 and 64 bit) are installed. if not, uninstall TDI, install them... then reinstall TDI and see what happens.
Tried this : yum upgrade libstdc++
yum install libstdc++.i686
yum upgrade zlib
yum install zlib.i686

still have exact same error message, thanks for the idea
a***@gmail.com
2016-01-25 19:09:59 UTC
Permalink
Post by a***@gmail.com
Post by @ErikSorensen
yeah - prereq site is down for me too. try checking that compat-libstdc++ (both 32 and 64 bit) are installed. if not, uninstall TDI, install them... then reinstall TDI and see what happens.
Tried this : yum upgrade libstdc++
yum install libstdc++.i686
yum upgrade zlib
yum install zlib.i686
still have exact same error message, thanks for the idea
TDI V7.1.1 installs and runs without issue on RHEL 7, so what does V7.2 need? Have done yum update and all of the RPMs listed on the IBM site, uninstalls , reinstalls. yum install compat-libstdc++* comes back with :
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package compat-libstdc++* available.
Error: Nothing to do
Jason Williams
2016-01-29 18:55:56 UTC
Permalink
Post by a***@gmail.com
Post by a***@gmail.com
Post by @ErikSorensen
yeah - prereq site is down for me too. try checking that compat-libstdc++ (both 32 and 64 bit) are installed. if not, uninstall TDI, install them... then reinstall TDI and see what happens.
Tried this : yum upgrade libstdc++
yum install libstdc++.i686
yum upgrade zlib
yum install zlib.i686
still have exact same error message, thanks for the idea
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package compat-libstdc++* available.
Error: Nothing to do
I have not tried this on RHEL7, though here are my notes on installing on a minimal RHEL6 install. Some of the same packages could be required.
http://www.evernote.com/l/AAW6j6pS5ZdPcqCm7MbiZN2y3L-gquhVyRw/
a***@gmail.com
2016-02-01 23:04:13 UTC
Permalink
Post by Jason Williams
Post by a***@gmail.com
Post by a***@gmail.com
Post by @ErikSorensen
yeah - prereq site is down for me too. try checking that compat-libstdc++ (both 32 and 64 bit) are installed. if not, uninstall TDI, install them... then reinstall TDI and see what happens.
Tried this : yum upgrade libstdc++
yum install libstdc++.i686
yum upgrade zlib
yum install zlib.i686
still have exact same error message, thanks for the idea
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
No package compat-libstdc++* available.
Error: Nothing to do
I have not tried this on RHEL7, though here are my notes on installing on a minimal RHEL6 install. Some of the same packages could be required.
http://www.evernote.com/l/AAW6j6pS5ZdPcqCm7MbiZN2y3L-gquhVyRw/
I did not completely uninstall and reinstall but this did not work yet. Will remove SDI in the future and retry, Any other ideas?
Marcello Barnaba
2020-10-23 23:02:28 UTC
Permalink
yeah - prereq site is down for me too. try checking that compat-libstdc++ (both 32 and 64 bit) are installed. if not, uninstall TDI, install them... then reinstall TDI and see what happens.
Tried this : yum upgrade libstdc++
yum install libstdc++.i686
yum install zlib.i686
Reviving this after 5 years, as same problems still happen and the IBM documentation sites are as well useless as they were 5 years ago.

For future readers, installing the following packages on CentOS 7.8

- libstdc++-compat-33.i686
- libstdc++-compat-33.x86_64
- libstdc++.i686
- zlib.i686

produced a working installation of TDI 7.2, that I am using for ISDS log management.

Thank you and kind regards!

Continue reading on narkive:
Loading...